Subscribe Contribute Advertise Facebook Twitter Instagram Forums Newsletter
Fuji X10 photos
Display Avatars Sort By:
Arapiles .
(Arapiles) - M

Locale: Melbourne
Fuji X10 photos on 04/20/2012 19:45:26 MDT Print View

I'd be interested in your thoughts on these photos with my new X10 - I was surprised by the resolution in some of the photos (strands of hair being visible etc) because that is what I used to get with my Contax T3 and the Fuji lens isn't nominally as high-range.

http://www.flickr.com/photos/11492450@N06/sets/72157629837912657/

I didn't have much time to read the manual etc before I went so I put it on EXR auto and left it at that.

As a first-time digital camera user I did enjoy having more than 36 frames available.

Jason Elsworth
(jephoto) - M

Locale: New Zealand
Fuji X10 photos on 04/20/2012 20:49:31 MDT Print View

I was on the verge of getting an X10, but in the end decided that the Olympus Z-1 with an EVF was a better choice for me. I really wanted a good view finder and will mainly use the camera outside at low ISO.

According to most reviews the X10 seemed to produce great results at the right settings (orb issue/non-issue aside, but wasn't very user friendly if you wanted to have manual control over the camera.

You have probably seen this - http://www.dpreview.com/articles/9311974549/getting-the-best-out-of-the-fujifilm-x10.

Franco Darioli
(Franco) - M

Locale: Melbourne
Fuji X10 photos on 04/20/2012 20:52:21 MDT Print View

There was a lot of talk about "white orbs" with that and I am sure that some were falling over each other trying their hardest to show just how much of that is there, however as your shots demonstrate in real life it isn't much of a problem if at all.
Franco
BTW, another pet peeve of mine is when folk buy a product wanting it to fail and doing their best to make it happen...
(seen here at BPL many times)
(Jason posted as I was typing my comment...)

Edited by Franco on 04/20/2012 20:53:40 MDT.

Arapiles .
(Arapiles) - M

Locale: Melbourne
Re: Fuji X10 photos on 04/21/2012 01:03:36 MDT Print View

Hi Jason

No, I hadn't seen that - thanks for the link.

I did ask about the orbs thing when I bought the camera and the shops in Melbourne said that they hadn't had any complaints. They were suggesting that it might be a batch thing and that perhaps the Australian batch didn't have the problem. In any case, if it does turn up I'll deal with it at the time.